Kalender

Kategori

Pesan Anda


ShoutMix chat widget

Browser Favorit

Blog Archive

Kenapa Mangle di Mikrotik Begitu Penting

Diposting oleh Anang Efendi On 18.39


Mangle merupakan metode bandwidth manajemen, kalau seandainya ingin bandwidth tersebut dibagi sama rata oleh Mikrotik.

seperti bandwidth 256kbps downstream dan 128kbps upstream. Sedangkan client yang akan mengakses sebanyak 10 client, maka otomatis masing-masing client mendapat jatah bandwidth downstream sebanyak 256kbps dibagi 10 dan upstream sebanyak 128kbps dibagi 10. Jadi masing-masing client mendapat 25,6kbps untuk downstream dan 12.8kbps untuk upstream. Andaikata hanya 2 Client yang mengakses maka masing-masing client dapat 128kbps untuk downstream dan 64kbps untuk upstream.


Untuk itu dipakai type PCQ (Per Connection Queue), yang bisa secara otomatis membagi trafik per client.
Tentang jenis queue di mikrotik ini dapat dibaca pada manualnya di http://www.mikrotik.com/testdocs/ros/2.9/root/queue.php .

Sebelumnya perlu dibuat aturan di bagian MANGLE. Seperti :
--------------------------------------------------------------------------------
/ip firewall mangle add chain=forward src-address=192.168.0.0/27 \ action=mark-connection new-connection-mark=users-con
/ip firewall mangle add connection-mark=users-con action=mark-packet \ new-packet-mark=users chain=forward
--------------------------------------------------------------------------------
Karena type PCQ belum ada, maka perlu ditambah, ada 2 type PCQ ini.Pertama diberi nama pcq-download, yang akan mengatur semua trafik melalui alamat tujuan/destination address. Trafik ini melewati interface Local. Sehingga semua traffik download/downstream yang datang dari jaringan 192.168.0.0/27 akan dibagi secara otomatis.
Tipe PCQ kedua, dinamakan pcq-upload, untuk mengatur semua trafik upstreamyang berasal dari alamat asal/source address. Trafik ini melewati interface public. Sehingga semua traffik upload/upstream yang berasaldari jaringan 192.168.0.0/27 akan dibagi secara otomatis.
Perintah:
---------------------------------------------------------------------------------
/queue type add name=pcq-download kind=pcq pcq-classifier=dst-address
/queue type add name=pcq-upload kind=pcq pcq-classifier=src-address
---------------------------------------------------------------------------------
Setelah aturan untuk PCQ dan Mangle ditambahkan, sekarang untuk aturanpembagian trafiknya. Queue yang dipakai adalah Queue Tree, Yaitu:
---------------------------------------------------------------------------------
/queue tree add parent=Local queue=pcq-download packet-mark=users
/queue tree add parent=Public queue=pcq-upload packet-mark=users
--------------------------------------------------------------------------------
Perintah diatas mengasumsikan, kalau bandwidth yang diterima dari providerInternet berflukstuasi atau berubah-rubah. Jika kita yakin bahwa bandwidthyang diterima, misalkan dapat 256kbs downstream, dan 128kbps upstream, maka ada lagi aturannya, seperti :
Untuk trafik downstreamnya :
--------------------------------------------------------------------------------
/queue tree add name=Download parent=Local max-limit=256k
/queue tree add parent=Download queue=pcq-download packet-mark=users
-------------------------------------------------------------------------------
Dan trafik upstreamnya :
-------------------------------------------------------------------------------
/queue tree add name=Upload parent=Public max-limit=128k
/queue tree add parent=Upload queue=pcq-upload packet-mark=users
-------------------------------------------------------------------------------

2 Response to "Kenapa Mangle di Mikrotik Begitu Penting"

  1. Arif Budiman Said,

    sipp om.... thanks ilmunya

     

  2. Anang Efendi Said,

    sama sama mas Arif Budiman

     

Posting Komentar

My Profile


"Everything is Possible with Programming"

Chatt yukk

Followers

Ada kesalahan di dalam gadget ini